Hi there,

If you go to appearance>theme settings> slider, check in the drop down that you have the slider set to display on either the frontpage or all pages. Screencast – http://screencast.com/t/VmLcuLjeHP

Make sure you have your front page set in wp admin> settings> reading, make sure it’s set to “your latest posts” if you want to replicate the demo.

More tips for the restaurant theme can be found at – https://support.redfactory.nl/documentation/restaurant-theme/

Let us know how you get on or if you require further assistance.