Hi there, the editor is in the wp admin> appearance > editor (usually at the bottom)

http://screencast.com/t/VFNxvQRGH

If you don’t have this, then you’re probably not listed as the site admin and have some other role which restricts your access to the wp-admin area. Speak to the site admin to check your user role and upgrade to a higher role as required.

If you mean the home text in the navigation, simply remove this link via wp-admin>appearance>menus and add in a link manually from the options on the left hand side, with your own label in the chosen language with the url for the homepage and slide into position and save.