Morning, yeah it’s working now, maybe site was just down for a bit yesterday?

Slider is there, it’s just set to not display until you click the arrow, then it shows – http://screencast.com/t/Bg0yufUuCej

So that means in the slider settings, you’ve checked one of the options to not display initially etc. Go to the wp-admin, appearance>theme settings and under the slider tab, you’ll see an option to hide/display etc. I’ve not the theme to hand atm as on another machine, so can’t screenshot the options. If you can’t find it, reply with login credentials (use the set as private reply option below so only I can see them) and I’ll login and adjust for you.