Ok, you had the slider settings correct, it was the home page in settings>reading you had wrong – http://screencast.com/t/W1TVuquxiy4

The homepage template uses the ‘latest posts’ option for this theme, not ‘static page’ so by switching back to that the slider and the correct widgets are no on the home page.