Hi there, check in appearance > theme settings > slider to see if you have the slider hidden on other pages checked – http://screencast.com/t/BHIOJKiwE

The slider is set to show only on the home page (set in settings>reading) by default, if you uncheck the option above then you can control where the slider appears – on static pages etc.