Hi Jackson

In appearance>themes>theme settings do you have the slider set to ‘only on the frontpage’? If so go to settings>reading and check in the drop down that you have that page you’re looking at set as the frontpage.

Looking in the html sourcecode, the slider is set to dispaly:none, so that would lead me to think that there’s something not set correctly in the settings if that is the frontpage.

Let me know.