It was my Reading section that wasn’t properly configured. But it seems like if I do that and choose Default Template that I lose those three custom boxes I’ve added in my widget section. Is there a way to enable or get them to display on the homepage? Thanks.