Fixed it. It was on my end. I had switched to a differnt IP address as well and I finally noticed that there was a space in the slider image’s url: (http://184.94.218.150 /wp-content/uploads/2014/02/Trattoria-Villagio-Italian-Restaurant-VA.jpg)

Trying different things to locate and remove the space, re-saving the general options did the trick.