For anyone interested I just followed this video and downgraded back to wp 4.0 and my theme seems to work ok http://www.youtube.com/watch?v=OwNR6NVhVFQ