This isn’t working for me. Maybe I do not understand. So I log into the menucard page (does it have to be called menucard?) and then at the bottom of the page where I have “menu” checked, I uncheck this and publish and then recheck it and publish and wordpress fixes things?

If this is what you are recommending, it is not working. Is there something else I can try?